Unable to create roles with 6.x

Referenced docs: https://gravitational.com/gravity/docs/config/#configuring-roles

Gravity Version: 6.1.5

Is the ability to create roles only supported within the Enterprise edition of Gravity? I’ve tried following the examples directly from the docs and gravity gives the following error showing role as an unsupported parameter:

[centos@gravity-demo1 ~]$ gravity resource create administrator.yaml
[ERROR]: unsupported resource "role", supported are: [cluster_auth_preference github auth_connector user token logforwarder smtp alert alerttarget tlskeypair authgateway runtimeenvironment clusterconfiguration]

Yea, it looks like role is provided in the enterprise sources, and this is our docs being misleading. I’ve submitted a quick PR to flag the role resource as Enterprise only similar to other resources.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.