Tsh --proxy=proxhost --cluster=clustername ssh clusternode no longer works as documented


#1

What happened:
$ tsh --cluster=od-server-00296 ssh od-server-00296 error: unknown long flag '--cluster'

What you expected to happen:
$ tsh --cluster=od-server-00296 ssh od-server-00296 od-server-00296$
As documented at: https://gravitational.com/teleport/docs/admin-guide/#trusted-clusters

Environment:

  • Teleport version (use teleport version): Teleport v3.0.0 git:v3.0.0-0-g017ae5f9
  • Tsh version (use tsh version):Teleport v3.0.0 git:v3.0.0-0-g017ae5f9
  • OS (e.g. from /etc/os-release):Ubuntu 16.04

#2

I think we switched --cluster to be ssh specific flag, not a global one anymore, does tsh ssh --cluster work?


#3

Can confirm, moving --cluster to after ssh works as expected. This ticket should probably be changed to a documentation bug then to update the linked section in the admin-guide to reflect this change