Teleport and ssh login have different ulimt open files

Hi i got problem recently
when i use ssh login, ulimt open files value was 65535(i have set this value before)
use teleport login, execute ulimt -n result was 1024(default value)
that cause Ansible throw too many open file error
emm,did we have some way to change this value?

You should probably look to set this in /etc/security/limits.d or whatever is appropriate for your Linux distribution.

The other thing is that usually ulimit overrides are done using via PAM - you might look at setting this in your Teleport config on the node:

teleport:
   ssh_service:
      pam:
         enabled: yes

thanks!
but already find other way to solve this problem
which is add LimitNOFILE=655350 to teleport.service [Service] section

1 Like

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.