Teleconsole failed to work behind a http proxy

I tried to evaluate if teleport can work behind an https proxy - so I started out with teleconsole since as far as I understand the underlying code is the same.

I defined the https_proxy and http_proxy environment variables - it worked since teleconsole was able to connect to teleconsole.com:443

But in the end I got the following error:

./teleconsole -v
INFO[0000] Ping http://eu.teleconsole.com/ping           file=geo/geo.go:40 
func=geo.FindFastestEndpoint.func1
INFO[0000] Ping http://as.teleconsole.com/ping           file=geo/geo.go:40 
func=geo.FindFastestEndpoint.func1
INFO[0000] Ping http://teleconsole.com/ping              file=geo/geo.go:40 
func=geo.FindFastestEndpoint.func1
INFO[0000] teleconsole.com responded in 139.340794ms     file=geo/geo.go:60 
func=geo.FindFastestEndpoint
INFO[0000] Getting version from https://teleconsole.com:443  file=clt/api_client.go:69 
func=clt.(*APIClient).CheckVersion
INFO[0005] Connecting to https://teleconsole.com:443     file=clt/api_client.go:105 func=clt. 
(*APIClient).CheckVersion
Starting local SSH server on localhost...
Requesting a disposable SSH proxy on teleconsole.com for ubuntu...
INFO[0006] Requesting a new session for ubuntu forwarding <nil>  file=clt/api_client.go:120 
func=clt.(*APIClient).RequestNewSession
Checking status of the SSH tunnel...
INFO[0020] Deleted session log at /tmp/cluster-teleconsole-client697478614  
file=clt/clt.go:188 func=clt.onStopBroadcast
SSH tunnel cannot be established, please try again.

Am I missing something?

Teleconsole is an older project and hasn’t been updated in quite some time. It’s not a good idea to use it as a reliable basis for testing whether or something wiill work with Teleport.

You can find details on how to use HTTP proxies with Teleport here -https://gravitational.co/teleport/docs/admin-guide/#http-connect-proxies

I would install Teleport locally using our quick start guide (https://gravitational.co/teleport/docs/quickstart/) and try it out. If you have any issues getting the HTTP proxy functionality to work, please post here and we can help.

Will do, thanks for the reply.

Let us know how you get on!

Teleport 4.1 worked behind an http_proxy in what is called tunneling mode.
Thanks Gus.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.