Release 6.2.2 / 6.1.8 / 6.0.10 / 5.5.25 Now Available

6.2.2 (October 17th, 2019)

Bugfixes

  • Upgrade Kubernetes to v1.16.02 (CVE-2019-11253) (#808).

Warning
This release fixes a security vulnerability in kubernetes. Please see
Kubernetes Announcement for more information.

6.1.8 (October 17th, 2019)

Bugfixes

  • Upgrade Kubernetes to v1.15.05 (CVE-2019-11253) (#809).
  • Fix an issue with upgrades related to fetching legacy teleport configuration (#809).

Warning
This release fixes a security vulnerability in kubernetes. Please see
Kubernetes Announcement for more information.

6.0.10 (October 17th, 2019)

Improvements

  • Add support for discovering upstream DNS servers from systemd-resolved configuration (#740).
  • Improve gravity report to capture additional network configuration (#769).

Bugfixes

  • Upgrade Kubernetes to v1.14.08 (CVE-2019-11253) (#810).
  • Fix the issue with join failing with “bad username or password” when using auto-scaling groups on AWS (#790).

Warning
This release fixes a security vulnerability in kubernetes. Please see
Kubernetes Announcement for more information.

5.5.26 (October 17th, 2019)

Bugfixes

  • Upgrade Kubernetes to v1.13.12 (CVE-2019-11253) (#811).
  • Fixes an issue with timeouts while validating agent connections (#777).
  • Fixes an issue where upgrade could fail with latest package not found error in gravity-site (#813).

Warning
This release fixes a security vulnerability in kubernetes. Please see
Kubernetes Announcement for more information.