Critical service ssh.node has exited with error ssh: cert is not yet valid, aborting

Upgraded a one-node teleport to 4.0.1.

Adding new node with the generated code:

sudo /usr/local/bin/tctl   nodes add     --ttl=5m     --roles=node | awk '/teleport start/{out=substr($0,3);next}
       /auth-server/{out=out RS $0;print out;out=""}
       {if(length(out))out=out RS $0}'

OUTPUT:

teleport start \
    --roles=node \
    --token=4349ecef71ec990507b5f9de28ac3724 \
    --ca-pin=sha256:... \
    --auth-server=10.11.1.11:3025

The above output is executed on the new node with additional parameters --debug and --insecure.

ERROR OUTPUT:

ERRO [PROC:1]    Critical service ssh.node has exited with error ssh: cert is not yet valid, aborting. service/signals.go:143

STACKTRACE:

ERROR REPORT:
Original Error: *errors.errorString ssh: cert is not yet valid
Stack Trace:
        /gopath/src/github.com/gravitational/teleport/lib/sshutils/server.go:521 github.com/gravitational/teleport/lib/sshutils.validateHostSigner
        /gopath/src/github.com/gravitational/teleport/lib/sshutils/server.go:496 github.com/gravitational/teleport/lib/sshutils.(*Server).checkArguments
        /gopath/src/github.com/gravitational/teleport/lib/sshutils/server.go:162 github.com/gravitational/teleport/lib/sshutils.NewServer
        /gopath/src/github.com/gravitational/teleport/lib/srv/regular/sshserver.go:495 github.com/gravitational/teleport/lib/srv/regular.New
        /gopath/src/github.com/gravitational/teleport/lib/service/service.go:1414 github.com/gravitational/teleport/lib/service.(*TeleportProcess).initSSH.func1
        /gopath/src/github.com/gravitational/teleport/lib/service/supervisor.go:452 github.com/gravitational/teleport/lib/service.(*LocalService).Serve
        /gopath/src/github.com/gravitational/teleport/lib/service/supervisor.go:242 github.com/gravitational/teleport/lib/service.(*LocalSupervisor).serve.func1
        /opt/go/src/runtime/asm_amd64.s:1338 runtime.goexit
User Message:

Any suggestions what could be checked?

ok it seems there is a time difference on the servers. :slight_smile: sorry for this question

Glad you were able to resolve the issue!