Adding a node to the cluster

ad 1. I have checked both scenarios - no difference.
ad 2. Yes I have
ad 3. Yes, I have deleted /var/lib/teleport on the master and two nodes I trying to connect. Still no luck.
on the master looping:

WARN [NODE:BEAT] Heartbeat failed all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
WARN [NODE:1:CA] Re-init the cache on error: all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
DEBU [NODE:1:CA] Reloading Linear(attempt=57, duration=10s). cache/cache.go:346
WARN [PROXY:1] Re-init the watcher on error: all SubConns are in TransientFailure, latest connection error: . services/proxywatcher.go:180
DEBU [PROXY:1] Reloading Linear(attempt=57, duration=10s). services/proxywatcher.go:184
WARN [PROXY:1:C] Re-init the cache on error: all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
DEBU [PROXY:1:C] Reloading Linear(attempt=57, duration=10s). cache/cache.go:346
WARN [REVERSE:D] Re-init the cache on error: all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
DEBU [REVERSE:D] Reloading Linear(attempt=57, duration=10s). cache/cache.go:346
WARN [NODE:BEAT] Heartbeat failed all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
WARN [NODE:BEAT] Heartbeat failed all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
WARN [NODE:1:CA] Re-init the cache on error: all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
DEBU [NODE:1:CA] Reloading Linear(attempt=58, duration=10s). cache/cache.go:346
WARN [PROXY:1] Re-init the watcher on error: all SubConns are in TransientFailure, latest connection error: . services/proxywatcher.go:180
DEBU [PROXY:1] Reloading Linear(attempt=58, duration=10s). services/proxywatcher.go:184
WARN [PROXY:1:C] Re-init the cache on error: all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188

on the node also looping:

WARN [NODE:BEAT] Heartbeat failed transport is closing. logrus/entry.go:188
WARN [PROC:1] Sync rotation state cycle failed: watcher has disconnected, going to retry after 10s. logrus/entry.go:188
WARN [NODE:BEAT] Heartbeat failed all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
WARN [NODE:BEAT] Heartbeat failed all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
WARN [PROC:1] Sync rotation state cycle failed: all SubConns are in TransientFailure, latest connection error: , going to retry after 10s. logrus/entry.go:188
WARN [NODE:BEAT] Heartbeat failed all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
WARN [NODE:BEAT] Heartbeat failed all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
WARN [PROC:1] Sync rotation state cycle failed: all SubConns are in TransientFailure, latest connection error: , going to retry after 10s. logrus/entry.go:188
WARN [NODE:BEAT] Heartbeat failed all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
WARN [NODE:BEAT] Heartbeat failed all SubConns are in TransientFailure, latest connection error: . logrus/entry.go:188
WARN [PROC:1] Sync rotation state cycle failed: all SubConns are in TransientFailure, latest connection error: , going to retry after 10s. logrus/entry.go:188

I think the only way will be switch back to version 3.x. Any other ideas ?
Regards,

P.

@piotrjaksa It looks like a failure to connect to the auth server. Can you please post your updated config? A small mistake in the config could cause a big problem so it’s important to make sure it’s correct.